绪山真寻bot | 部分问题的解决办法
本文发布于292天前,最后更新于210天前,其中的信息可能有所发展或是发生改变。如有疑问请联系邮箱:admin@yemengstar.com。

1.【已解决】gocq启动时报code45

解决办法看这篇文章:使用qsign解决gocq启动code45报错 – 夜梦星尘の折腾日记 (yemengstar.com)

2.【可能解决】无法识别“poetry”

夜梦折腾了好久,终于得出了一个结论:

你环境爆炸了!重开吧!

反正夜梦倒腾了好久莫名其妙就好了……

或许你可以重装poetry > > 重装python > > 重装系统 > > 重买电脑。

重装poetry:Introduction | Documentation | Poetry – Python dependency management and packaging made easy (python-poetry.org)

3.【未解决】poetry install报错,无法安装pyyaml

考虑降低python版本,如果你安装的是3.10,尝试降低到3.9再次尝试。

可供参考方案:poetry install报错 · Issue #1469 · HibiKier/zhenxun_bot (github.com),然而并没有成功。

夜梦翻遍了GitHub也没有找到有用的方法,尝试了许多方案均已失败告终。如果你在这里栽了跟头,夜梦劝你直接换一个QQ机器人吧,别费劲了……

4.数据库问题

一般是数据库用户名密码错了,建议重新建一个数据库。或者干脆卸了重装完全参考官方的操作(用户名密码),反正没人攻击你数据库= =

5.【可能解决】No module named ‘nonebot’等依赖

最大的可能性为没有装全依赖库,可以尝试进入虚拟环境后,在真寻bot文件夹内,执行:

pip install

若不行,你可以自行安装依赖,具体依赖有(V0.1.6.7):

自己用poetry help查找所需要的安装包,然后放在一个txt文件里面,例如requirements.txt,然后用指令下载,记得先删除poetry的虚拟环境所在的文件夹,ubuntu下为/root/.cache/pypoetry/virtualenvs。然后进入虚拟环境,使用pip3 install -r requirements.txt -i https://pypi.tuna.tsinghua.edu.cn/simple 安装

aiofiles==0.8.0
aiohttp==3.7.4.post0
aiosqlite==0.17.0
anyio==3.6.2
apscheduler==3.9.1.post1
async-timeout==3.0.1
asyncpg==0.27.0
attrs==22.2.0
beautifulsoup4==4.9.3
bilireq==0.2.3.post0
black==22.12.0
cachetools==5.2.0
cattrs==22.2.0
certifi==2022.12.7
chardet==4.0.0
click==8.1.3
cn2an==0.5.19
colorama==0.4.6
commonmark==0.9.1
contourpy==1.0.6
cycler==0.11.0
dateparser==1.1.4
ecdsa==0.18.0
emoji==1.7.0
exceptiongroup==1.1.0
fastapi==0.88.0
feedparser==6.0.10
fonttools==4.38.0
greenlet==2.0.1
grpcio==1.51.1
h11==0.14.0
httpcore==0.16.3
httptools==0.5.0
httpx==0.23.1
idna==3.4
imagehash==4.3.1
importlib-metadata==5.2.0
iso8601==1.1.0
jieba==0.42.1
jinja2==3.1.2
kiwisolver==1.4.4
loguru==0.6.0
lxml==4.6.5
markdown==3.4.1
markupsafe==2.1.1
matplotlib==3.6.2
msgpack==1.0.4
multidict==6.0.3
mypy-extensions==0.4.3
nonebot-adapter-onebot==2.2.0
nonebot-plugin-apscheduler==0.2.0
nonebot-plugin-htmlrender==0.2.0.1
nonebot2==2.0.0rc2
numpy==1.24.0
opencv-python==4.6.0.66
packaging==22.0
pathspec==0.10.3
pillow==9.3.0
platformdirs==2.6.0
playwright==1.29.0
proces==0.1.3
protobuf==4.21.12
psutil==5.9.4
pyasn1==0.4.8
pydantic==1.10.2
pyee==9.0.4
pygments==2.13.0
pygtrie==2.5.0
pymdown-extensions==9.9
pyparsing==3.0.9
pypika-tortoise==0.1.6
pypinyin==0.46.0
python-dateutil==2.8.2
python-dotenv==0.21.0
python-jose==3.3.0
python-markdown-math==0.8
python-multipart==0.0.5
pytz==2022.7
pytz-deprecation-shim==0.1.0.post0
pywavelets==1.4.1
pyyaml==5.4.1
regex==2022.10.31
retrying==1.3.4
rfc3986==1.5.0
rich==12.6.0
rsa==4.9
ruamel.yaml==0.17.21
ruamel.yaml.clib==0.2.7
scipy==1.9.3
setuptools-scm==7.1.0
sgmllib3k==1.0.0
six==1.16.0
sniffio==1.3.0
soupsieve==2.3.2.post1
starlette==0.22.0
tomli==2.0.1
tomlkit==0.11.6
tortoise-orm==0.19.3
typing-extensions==4.4.0
tzdata==2022.7
tzlocal==4.2
ujson==5.6.0
uvicorn==0.20.0
watchfiles==0.18.1
websockets==10.4
win32-setctime==1.1.0
wordcloud==1.8.2.2
yarl==1.8.2
zipp==3.11.0

参考方案:

6.其他问题

你可以尝试更改python版本进行重新尝试,但是不保证可行性。夜梦已经很久没有使用过真寻bot了,如果在部署过程中有疑问,建议前往GitHub提交issue,由有经验的大佬进行解答。你也可以去官方萌新交流群【是真寻酱哒(萌新版)  】中寻找大佬进行解答。

本文为夜梦星尘原创文章。
文章作者:夜梦星尘
文章链接:绪山真寻bot | 部分问题的解决办法
版权声明:本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自夜梦星尘
支持作者:夜梦星尘的爱发电
上一篇
下一篇